MJBoxSystem Requirements

MasterJuggler 3 requires OS X 10.1 through 10.6.x. OS X 10.2.x-10.6.x is recommended. MasterJuggler is not (at this time) compatible with OS X 10.7 through 10.13.

If your Mac is running Mac OS 9.2.2 or earlier, MasterJuggler Pro 2.1.1 is still available for purchase directly from Alsoft. Please contact our Sales Department to order.

item6
item5a1
item4
Alsoft Logo
Alsoft30Years
BUY NOW
UPGRADE